Upgrading to V1.5 Fails

With the release of V1.5, older versions ClockMaker will prompt you to upgrade. Unfortunately the file download mechanism broke and it will fail to find the file. We apologize for this, this was due to adding secure weblinks (https://) and the upgrade process was using the old ways of getting the files. We have changed the upgrade process in V1.5 going forward.

WINDOWS
You can download the updated V1.5 ClockMaker here

MAC
You can download the updated V1.5 ClockMaker here

ClockMaker Failed Update

Still need help? Contact Us Contact Us